import re
regex = re.compile(r"^(0{0,2}\+?389[\s./-]?)(\(?[0]?[7-7][0-9]\)?[\s./-]?)([2-9]\d{2}[\s./-]?\d{3})$", flags=re.MULTILINE)
test_str = ("+389 70 123 456\n"
"389-71-234-567\n"
"389-071-234-567\n"
"389-0071-234-567\n"
"00389.72.345.678\n"
"+389/73/456/789\n"
"389 75 123456\n"
"389 76-234-567\n"
"+38970123456\n"
"38971234567\n"
"0038972345678\n"
"+38973456789\n"
"38975123456\n"
"38976234567\n"
"38980123456\n"
"+38982123456\n"
"+389 70 123-456\n"
"+389 70 323-456\n"
"389(71)234.567\n"
"389(071)234.567\n"
"00389/723-456-78\n"
"+389 (73) 456.789\n"
"389 75 123/456\n"
"389 76-234.567\n"
"389.80.123.456\n"
"389.(080).123.456\n"
"+389-82-123-456\n"
"00389 (81) 234-56\n"
"389/931-234-56\n"
"+3899512-3456\n"
"00389(95)12.345\n"
"389/10-123-456\n"
"389 11-123/456\n"
"+389 12.123-456")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")