package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<cRegexGroupsName>\d{9})`)
var str = `presentacion aeat 123456781 13122021`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}