#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?_ExampleXML_(.*?)_2021\d+\.xml$"
Local $sString = "First_ExampleXML_Only_This_Should_Be_Name_20211234567.xml" & @CRLF & _
"Second_ExampleXML_OnlyThisShouldBeName_202156789.xml" & @CRLF & _
"Third_ExampleXML_Only_This_Should_Be_Name1_2021445678.xml" & @CRLF & _
"Fourth_ExampleXML_Only_This_Should_Be_Name2_20214567.xml"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")