re = /{+[^}]*}*(?!.*{)/mi
str = '{{token1}}/{{token2}}
{{token1}}/{
{{token1}}/{{
{{token1}}/{{'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end