re = /(?P<key>\b[A-Z][ a-z_()]*): *(?P<value>.+?)(?=\b[A-Z][ a-z_()]*:|$)/m
str = 'Latitude (degrees): 4010.44 Longitude (degrees): 58.000 Radiation database: year month H(h)_m 2005 Jan 57.77 2005 Feb 77.76 2005 Mar 120.58 H(h)_m: Irradiation plane (kWh/m2/mo)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end