re = /\w+,\s+\w+\s+\d+\,\s+\d+\s+at\s+\d+:\d+(pm|am)\s+\w{3}/
str = '08/04/16 11:26:44'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end