$re = '/.*(?<!\.csv)(\.csv)$/m';
$str = 'abc.csv
abc.csv.gz
abc.def.csv
abc.csv.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);