package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(x|y|z)`)
var str = `xsdfysdfz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}