import Foundation
let pattern = #"^[A-Z]{4,5}_((?![^_]*(?i:test))[^_]*)_\d{6}_\d_.{2}\d_.{2}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
ABCD_EFGHI-78-32#1-R77.2_301009_1_AB3_CD
ABCD_EFGHI-78-32#1-TEST-R77.2_301009_1_AB3_CD
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)