$re = '/^(?=[\d.]{1,10}$)(?:\d+(?:\.\d+)?|\.\d{1,8})$/m';
$str = '1234567890
12345678.9
123456.789
123.456789
12.3456789
1.23456789
0.12345678
.12345678
.123456789
0.123456789
1.234567890
12345678901
123456789.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);