// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w+)(\(⁰([\S\s]*?)\)⁰)?[.]?").unwrap();
let string = "auoeu ueu(⁰ueuou)⁰.bnthnh(⁰ueuou(u) + uooeu)⁰.c = ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}