$re = '/(?!(?:000|666|9))\d{3}-(?!00)\d{2}-(?!0000)\d{4}/m';
$str = '123-45-6789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);