$re = '/(?si)(?:\G(?!\A)|\bHello\b)(?:(?!\bHello\b).)*?\K\bnumber\s*\d+(?=.*?\bRegards\b)/mis';
$str = 'This is my test text number 25120
Hello my name is testing
I\'m 20 years old
Please help me with the regex number 1542
I have been trying to create the regex many times this is my number 5152
Regards
I\'m still trying my attempt number 5150';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);