const regex = /^(((19|[2-9][0-9])[0-9][0-9])-(((0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-8]))|((0[13578]|1[02])-(29|30|31))|((0[4,6,9]|11)-(29|30))))|((19|[2-9][0-9])(00|04|08|12|16|20|24|28|32|36|40|44|48|52|56|60|64|68|72|76|80|84|88|92|96)-02-29)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((19|[2-9][0-9])[0-9][0-9])-(((0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-8]))|((0[13578]|1[02])-(29|30|31))|((0[4,6,9]|11)-(29|30))))|((19|[2-9][0-9])(00|04|08|12|16|20|24|28|32|36|40|44|48|52|56|60|64|68|72|76|80|84|88|92|96)-02-29)$', 'gm')
const str = `1900-03-29`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}