import re
regex = re.compile(r"!([^|!]*(?:jpe?g|png|gif|pdf|xlx))(?:\|width=(\d*\.?\d+%?)(?:,height=(\d*\.?\d+%?))?)?!", flags=re.MULTILINE)
test_str = ("!img2.png|width=83.33333333333334%!\n"
" \n"
" !robot (f05f0216-caf4-4543-a630-99c2477849d5).png|width=400,height=400!\n"
" \n"
" fefeeef !abc.pdf|width=200!\n"
" \n"
" !dfe.xlx !abcd.xlx!")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")