$re = '/\/page(?=\?).*[?&]target=[^&\s]*(&|$)/m';
$str = '/page?foo=bar&target=1&test=1 <- should match
/page?target=1&test=2 <- should match
/page?test=2&target=1
/page/nested?foo=bar&target=1&test=1 <- should NOT match
/page/nested?target=1&test=2 <- should NOT match
/another-page?foo=bar&target=1&test=1 <- should NOT match
/another-page?target=1&test=2 <- should NOT match
/page?a-target=1&test=2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);