package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)\("(.+)"\)`)
var str = `hello("test")`
var substitution = "$1\\(["|']$2["|']\\)"
fmt.Println(re.ReplaceAllString(str, substitution))
}