package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\p{sc=Bengali}\s]+$`)
var str = `আমি আমি`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}