$re = '/(^|[^0-9])12($|[^0-9])/m';
$str = '1\\n2\\n4\\n5\\n7\\n8\\n9\\n12\\n13';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);