$re = '/background-image: url\(?(.+)\)
/m';
$str = 'background-image: url(img/cap.jpg)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);