const regex = /\[?\s*(\d+)\s*(?=(?:,\s*\d+)+|\])(?=[^\[]*\])./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[?\\s*(\\d+)\\s*(?=(?:,\\s*\\d+)+|\\])(?=[^\\[]*\\]).', 'g')
const str = `there were 4 cats [ 85] and 3 dogs [4,14][2] [3]
there are 17 cats [1 , 2,3,4,5]
these were my favorite paragraphs [1, 2, 75, 99]
the children's ages were 1, 4, and 12 [4,3, 2, 17,7,10]
As you can see it handles numbers outside of citations, multiple citations pretty well.
However it does depend on a fairly reliable citation format.`;
const subst = `[$1]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);