$re = '/\w+-\w+-(\w+)\\\\\w+/m';
$str = 'xyz123-xyz123-Suchstring\\xyz123
asd-schjs89ich-AIOSJDOAISJDIOAJSIODJASD\\asdasdasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);