package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/([^/_]{2})[^/]*$`)
var str = `path/stack/over_flow/Pedro_account`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}