$re = '/(\d{1,2}\.\d{1,2})|(\d{1,2})/';
$str = '1
55
55.66
99.9
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);