using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*2\.\K\d+(?=\.0\b)";
string input = @"https://example.com/repository/local/foo-bar/2.15290.0/foo_bar-2.15290.0.tar.gz";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}