$re = '/(?=[^ \t]*[/-])([0-9a-zA-Z/-]+)/m';
$str = 'Bill No: THRD/20-21/110
CRN No: GSTASP/20-21/066
Identifier value: PCPL-2021-000152
PCPL-2021-000152 is the ID';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);