import re
regex = re.compile(r":(\s{2,})[\n|\w.]$", flags=re.MULTILINE)
test_str = (" no_result:\n"
" label: Nous n'avons pas trouvé de bien correspondant à la recherche.\n"
" suggestion: Suggestion de biens dans les environs\n"
" change_criteria: Vous pouvez modifier les critères de\n"
" of: de\n"
" or: ou de\n"
" filter:\n"
" type: type de bien\n"
" location: localisation\n"
" size: nombre de pièces\n"
" price: budget\n"
" style: style de bien")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")