re = /(\s|^)Firefox\s?\/\s?(6[0-9]|[7-9][0-9]|\d{3,})(\.|\s|$)/i
str = 'Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0'
# Print the match result
str.match(re) do |match|
puts match.to_s
end