$re = '/\$\d+(?:,\d+)?(?:\h+AUD)?\b|\d+(?:,\d+) AUD\b/m';
$str = '$20,000 AUD
$20,000
20,000 AUD
$
20,000
AUD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);