$re = '/[a-zA-Z]+/';
$str = 'cama carro There is
Hola abcd 12324
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);