package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\{\s*run(?:\s+-(?<flags>[a-z]+(?:\s*-[a-z]+)*))*\s+(?<files>[\w.]+(?:\s+[\w.]+)*)\s*\}$`)
var str = `{ run }
{ run file1 }
{run -abc file1.foo file2.bar }
{ run -ab -ogg -fgg file1.baz file2}
{run -f-a-ob file1 file2.biz}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}