$re = '/^[NEOS]{1,3}$/m';
$str = 'S
SE
N
E
NNO
SO
NO';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);