use strict;
my $str = '@php($hiddenUrl = !empty($hiddenUrl) ?? false)\\r\\n
<span class="info__item">\\r\\n
@if($hiddenUrl)\\r\\n
<div class="info__icon" style="background-image: url(\'{{ $image }}\');" title="{{ $name }}"></div>\\r\\n
@else\\r\\n
<a class="info__icon" style="background-image: url(\'{{ $image }}\');" href="{{ $url }}" title="{{ $name }}"></a>\\r\\n
@endif\\r\\n
</span>';
my $regex = qr/@php\((.*?)\)(?= @php|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}