use strict;
my $str = '1000
AAAAAAAAAA
100,000.00
2000
BBBBBBBBBB
200,000.00
3000
CCCCCCCCCC
300,000.00
4000
DDDDDDDDDD
400,000.00';
my $regex = qr/(\d+)\n(\w+)\n([\d,.]+)/mp;
my $subst = '$1,$2,$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";