$re = '/^[0-9]{3}[0-9a-zA-Z]{5}[0-9]/';
$str = '3133A2ab1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);