package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-\d+(\.\d*)*`)
var str = `<div style="color: red; display.: inline-block;"><i class="fa fa-arrow-down" aria-hidden="true"></i> -1%</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}