package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)color\((\w+)\)`)
var str = `color(black)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}