package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?<quote>["']).*?\k<quote>`)
var str = `something "quoted here" not here 'here again'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}