import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9][0-9abAB]*$";
final String string = "1\n"
+ "25\n"
+ "15a\n"
+ "45B\n"
+ "2A\n"
+ "53b\n"
+ "96\n\n"
+ "A\n"
+ "a\n"
+ "B\n"
+ "b\n"
+ "B76\n"
+ "a34";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}