$re = '/(?<![青赤\n\r\t])+巻紙/m';
$str = '赤巻紙
青巻紙
黄巻紙
巻紙';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);