re = /^(?:(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])\.){3}(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])$/
str = '123.232.12.23
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result