re = /[0-9]{3}(-| )[0-9]{3}(-| )[0-9]{4}/m
str = '123-456-7890
1234567890
123 456 7890
123-456-789
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end