package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/\*-{78}\n(?<title> {4}.+?: .+\n)?[\n \t]+(?<desc>^ {4}(?:.+|\n)+?\n)?[\n \t]+(?<remarks>^ {4}(?:.+|\n)+?\n)?[\n \t]+(?<cols>^ {4}Columns:(?:.+|\n)+?\n)?[\n \t]+(?<cons>^ {4}Constraints:(?:.+|\n)+?\n)?[\n \t]+(?<tags>^ {4}Tags:(?:.+|\n)+?)?^\*\/ *\n`)
var str = `/*------------------------------------------------------------------------------
Table: ext.tenant
Highest division in the database, used to separate platform clients.
And this is the other part.
These are the remarks. Tha can span many many lines.
With beautiful explanations.
And many other comments.
Columns: MTLP
isenabled - [ ] True if marked as enabled. Used arbitrarily by businesss logic.
isdefault - [ ] True if the default entity within its context (only one allowed per system).
code - [ ] Short code representing the entity {unique, max 10 chars}.
name - [ ] Short name of the entity {unique, max 100 chars}.
notes - [ ] Optional notes with a longer description of the entity.
mailtransport - [ ] Mail transport used by this tenant for sending emails (smtp, ses).
Constraints:
country_uk_iso3 - @omit
country_uk_isonumeric - @omit
country_uk_country - @omit
Tags:
Tenancy - [ ] local [ ] shared [x] global
Association - [x] root [ ] aggreg. [ ] composed
Identity - [x] normal [ ] extension [ ] assoc.
Scale - [x] small [ ] medium [ ] large [ ] huge
Mutability - [ ] nerver [x] low [ ] medium [ ] high
*/
CREATE TABLE ext.tenant (
id UUID NOT NULL DEFAULT uuid_generate_v4(),
createdon TIMESTAMPTZ NOT NULL DEFAULT now(),
updatedon TIMESTAMPTZ NOT NULL DEFAULT now(),
-- Properties
isenabled BOOLEAN NOT NULL DEFAULT TRUE,
isdefault BOOLEAN NOT NULL DEFAULT FALSE,
code TEXT NOT NULL,
name TEXT NOT NULL,
notes TEXT,
mailtransport TEXT NOT NULL DEFAULT 'smtp',
-- Constraints
CONSTRAINT tenant_pk PRIMARY KEY (id),
CONSTRAINT tenant_uk_code UNIQUE (code) DEFERRABLE INITIALLY IMMEDIATE,
CONSTRAINT tenant_uk_name UNIQUE (name) DEFERRABLE INITIALLY IMMEDIATE,
CONSTRAINT tenant_ck_updatedon CHECK (updatedon >= createdon),
CONSTRAINT tenant_ck_code CHECK (char_length(code) < 20),
CONSTRAINT tenant_ck_name CHECK (char_length(name) < 100),
CONSTRAINT tenant_ck_mailtransport CHECK (mailtransport = ANY (ARRAY['smtp','ses']))
);
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}