#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?<==\h)\([A-Z][A-Z0-9_]+\b(?=[<:\;])|\b(?<!<)[A-Z][A-Z0-9_]+(?=[^>\)]))\b|\b((?<!=\s)(?<!\.)[A-Z]+\d*?(?![\(\;:])(?=[,\)>\s]))\b"
Local $sString = "This still has a problem with FOUR+ character match " & @CRLF & _
"\b(?<!val\s)(?<!var\s)(?<!=)(?<!=\s)(?<!\.)([A-Z]{1,3}[0-9]*?)\b" & @CRLF & _
"\b(?<!val\s|var\s|=|=\s|\.)([A-Z]+|[A-Z0-9]+)\b" & @CRLF & _
"\b([A-Z0-9]{1,3})\b(?![\(;:])(?=[,\)> ])" & @CRLF & _
"<[A-Z0-9]+>|\([A-Z0-9]+\)" & @CRLF & _
"\b([A-Z0-9]{1,3})\b" & @CRLF & _
"" & @CRLF & _
"<in T, out R>" & @CRLF & _
": R {" & @CRLF & _
": R =" & @CRLF & _
"(S, T, R)" & @CRLF & _
"(S)" & @CRLF & _
"-> S" & @CRLF & _
"-> (S)" & @CRLF & _
"" & @CRLF & _
"[^a-z:\s\.\,]" & @CRLF & _
"" & @CRLF & _
"<>" & @CRLF & _
":\w+(?=,|>)" & @CRLF & _
"" & @CRLF & _
"//-------------------" & @CRLF & _
"" & @CRLF & _
"class IO<out A>(val fn: () -> A) { // blows the stack" & @CRLF & _
" fun <B> map(g: (A) -> B): IO<B> = IO { g(this()) }" & @CRLF & _
" fun <B> flatMap(g: (A) -> IO<B>): IO<B> = IO { g(this())() }" & @CRLF & _
"" & @CRLF & _
" operator fun invoke(): A = fn()" & @CRLF & _
"" & @CRLF & _
" companion object {" & @CRLF & _
" val empty: IO<Unit> = IO {}" & @CRLF & _
" operator fun <A> invoke(a: A): IO<A> = IO { a }" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"// blows the stack" & @CRLF & _
"fun <A, B> forever(ioa: IO<A>): IO<B> {" & @CRLF & _
" val t: () -> IO<B> = { forever(ioa) }" & @CRLF & _
" return ioa.flatMap { t() }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"var count = 0" & @CRLF & _
"val program: IOU = IO {" & @CRLF & _
" forever<String, String>(IO { "${count++} Repeating function" })" & @CRLF & _
" .flatMap { Console.println(it) }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"//-----------------------" & @CRLF & _
"" & @CRLF & _
"class State<S, out T>(val runState: (S) -> Pair<S, T>) {" & @CRLF & _
"" & @CRLF & _
" fun <R> map(f: (T) -> R): State<S, R> =" & @CRLF & _
" flatMap { t -> pure<S, R>(f(t)) }" & @CRLF & _
"" & @CRLF & _
" fun <P15, R> map(sx: State<S, P1>, f: (T, P1) -> R): State<STAB, R> =" & @CRLF & _
" flatMap { t -> sx.map { x -> f(t, x) } }" & @CRLF & _
"" & @CRLF & _
" fun <R> flatMap(f: (T) -> State<S, R>): State<S, R> =" & @CRLF & _
" State { s ->" & @CRLF & _
" val (s1, t) = runState(s)" & @CRLF & _
" f(t).runState(s1)" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" companion object {" & @CRLF & _
" fun <S, T> pure(t: T): State<S, T> =" & @CRLF & _
" State { s -> s to t }" & @CRLF & _
"" & @CRLF & _
" fun <S> get(): State<S, S> =" & @CRLF & _
" State { s -> s to s }" & @CRLF & _
"" & @CRLF & _
" fun <S> set(newState: S): State<S, Unit> =" & @CRLF & _
" State { _ -> newState to Unit }" & @CRLF & _
"" & @CRLF & _
" fun <S> modify(f: (S) -> S): State<S, Unit> =" & @CRLF & _
" get<S>().flatMap { s: S -> set(f(s)).map { Unit } }" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"//----------------" & @CRLF & _
"" & @CRLF & _
"data class Book(" & @CRLF & _
" val ISDN: String," & @CRLF & _
" val name: String," & @CRLF & _
" val pages: Int," & @CRLF & _
" val price: Price," & @CRLF & _
" val weight: Double," & @CRLF & _
" val year: Int," & @CRLF & _
" val author: String" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"//-------------------" & @CRLF & _
"" & @CRLF & _
"fun <S, A> StateAlias<S, A>.map(f: (A) -> Boolean): StateAlias<S, Boolean> =" & @CRLF & _
" { s ->" & @CRLF & _
" val (s1, t) = this(s)" & @CRLF & _
" when {" & @CRLF & _
" f(s1) -> Pair(true, t)" & @CRLF & _
" else -> Pair(false, t)" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
"fun <S, A, B> flatMap(): ((StateAlias<S, A>) -> (A)) -> ((A) -> (StateAlias<S, B>)) -> StateAlias<S, B>" & @CRLF & _
"" & @CRLF & _
"//--------------------" & @CRLF & _
"" & @CRLF & _
"val dog = Dog(id = 0, name = "Doglin", furColour = FurColour.BLACK" & @CRLF & _
"" & @CRLF & _
"val cat: DOG = DOG" & @CRLF & _
"" & @CRLF & _
"//-------------------" & @CRLF & _
"" & @CRLF & _
"fun <T : Comparable<T>> sort(list: List<T>)" & @CRLF & _
"" & @CRLF & _
"fun <T> cloneWhenGreater(list: List<T>, threshold: T): List<T>" & @CRLF & _
" where T : Comparable," & @CRLF & _
" T : Cloneable {" & @CRLF & _
" return list.filter { it > threshold }.map { it.clone() }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"//----------------------" & @CRLF & _
"" & @CRLF & _
"enum class FurColour { BLACK, GREEN, PATCHED; }" & @CRLF & _
"" & @CRLF & _
"enum class Direction {" & @CRLF & _
" NORTH, SOUTH, WEST, EAST" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"enum class Color(val rgb: Int) {" & @CRLF & _
" RED(0xFF0000)," & @CRLF & _
" GREEN(0x00FF00)," & @CRLF & _
" BLUE(0x0000FF)" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"enum class ProtocolState {" & @CRLF & _
" WAITING {" & @CRLF & _
" override fun signal() = TALKING" & @CRLF & _
" }," & @CRLF & _
"" & @CRLF & _
" TALKING {" & @CRLF & _
" override fun signal() = WAITING" & @CRLF & _
" };" & @CRLF & _
"" & @CRLF & _
" abstract fun signal(): ProtocolState" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")