import Foundation
let pattern = #"^\d+\s+.+?\s+(\d+,\d{2})\s[\s\S]+?Materialnummer:\s+(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Bestellung
Information
Lieferantenanschrift
Firma Belegnummer 7700085038
Liefer GmbH Datum 13.07.2017
Musterstr. 9 Seite 1 von 3
D-123456 Musterhausen Lieferantennummer 10005750
Fax: +49451300966666 Währung EUR
Anlieferanschrift Einkäufer Willi Wichtig
Kaufhausen GmbH Telefon +49 4941 9777 777
Willi Schmalhans Fax-Nr +49 4941 977 7777
Kaufstraße 0815 e-Mail willi.schmalhans@kaufhausen.de
D-123456 Konkursstadt
Rechnungsadresse
Firma
Kaufhausen GmbH
Ausverkaufstr. 13
D-123456 Konkursstadt
UST-ID: DE111111111
Zahlungsbedingungen: innerhalb 30 Tage 3% Skonto / 60 Tage netto Liefertermin: 18.07.2017
Lieferbedingungen: DAP Anlieferadresse
Für Fragen zu Bedingungen des Rahmenvertrages, wenden Sie sich bitte an den verantwortlichen Materialgruppen-Einkäufer.
Bei Abstimmungsbedarf zu dieser vorliegenden Bestellung steht Ihnen der o.g. Ansprechpartner gerne zur Verfügung.
Hiermit bestellen wir gemäß der Incoterms® 2010 und unseren Einkaufsbedingungen vom 01.10.2015, die Sie im Internet unter
www.kaufhausen.de\Einkaufsbedingungen einsehen können.
Bitte achten Sie auf das Pflichtenheft für Lieferanten - nur(!) relevant für die LKW Warenanlieferung in das Industriegebiet Nord in
Konkursstadt
Nur so können die Anlieferverkehre weiterhin optimiert und die Wartezeiten entsprechend verkürzt werden!
Die Meldestelle ist => KAUFHAUSEN Logistikplatz: Elsterweg 15, 123456 Konkursstadt
Position Materialbeschreibung Menge Einheit Preis pro Einheit Nettobetrag
10 M.Gewindeb. M D371B HSSEM10 VA 5,00 ST 10,92 / 1 ST 54,60
FORUM
Ihre Materialnummer: 4214404285
Durchgangsloch-Maschinengewindebohrer, 2 x D Durchgangsloch, Oberfläche dampfbehandelt # Metrisches
ISO-Gewinde DIN 13 # Form B mitSchälanschnitt (3,5#5 Gang) # Gerade genutet # Toleranz ISO 2 6H # 2 x D
Durchgangsloch
Kostenstelle : 365310
................................................................................................................................................................................................................................................
Kaufhausen GmbH# Sitz und Registergericht: Konkursstadt # Registernummer: HRB 1111 # Geschäftsführer: Dipl.Ing. D.Katzenberger
Bankverbindung: Heassische Landesbank: IBAN: DE99 9999 9999 9999 9999 30 # BIC: WELA DE DD # USt-ID-Nr. DE 111111111
Kaufhausen GmbH# Ausverkaufstr. 13 # 123456 Konkursstadt Bestellung
Information
Lieferantenanschrift Belegnummer 7700085038
Firma Datum 13.07.2017
Liefer GmbH Seite 2 von 3
Musterstr. 9
D-123456 Musterhausen
Fax: +49451300966666
Position Materialbeschreibung Menge Einheit Preis pro Einheit Nettobetrag
20 M.Gewindeb. M D371B HSSEM8 VA FORUM 5,00 ST 9,05 / 1 ST 45,25
Ihre Materialnummer: 4214404282
Durchgangsloch-Maschinengewindebohrer, 2 x D Durchgangsloch, Oberfläche dampfbehandelt # Metrisches
ISO-Gewinde DIN 13 # Form B mitSchälanschnitt (3,5#5 Gang) # Gerade genutet # Toleranz ISO 2 6H # 2 x D
Durchgangsloch
Kostenstelle : 365310
................................................................................................................................................................................................................................................
30 M.Gewindeb. M D371B HSSEM6 VA FORUM 5,00 ST 7,49 / 1 ST 37,45
Ihre Materialnummer: 4214404279
Durchgangsloch-Maschinengewindebohrer, 2 x D Durchgangsloch, Oberfläche dampfbehandelt # Metrisches
ISO-Gewinde DIN 13 # Form B mitSchälanschnitt (3,5#5 Gang) # Gerade genutet # Toleranz ISO 2 6H # 2 x D
Durchgangsloch
Kostenstelle : 365310
................................................................................................................................................................................................................................................
_________________
Gesamtnettowert EUR 137,30
_________________
Kaufhausen GmbH# Sitz und Registergericht: Konkursstadt # Registernummer: HRB 1111 # Geschäftsführer: Dipl.Ing. D.Katzenberger
Bankverbindung: Hessische Landesbank: IBAN: DE99 9999 9999 9999 9999 30 # BIC: WELA DE DD # USt-ID-Nr. DE 111111111
Kaufhausen GmbH# Ausverkaufstr. 13 # 123456 Konkursstadt Bestellung
Information
Lieferantenanschrift Belegnummer 7700085038
Firma Datum 13.07.2017
Liefer GmbH Seite 3 von 3
Musterstr. 9
D-123456 Musterhausen
Fax: +49451300966666
Sehr geehrte Damen und Herren,
um den Bestellprozess reibungslos abwickeln zu können, beachten Sie bitte die folgenden Punkte.
Bitte notieren Sie auf jeglichem Schriftverkehr (z.B. Lieferschein, Rechnungen #) unsere Bestellnummer .
Die Rechnungs- und Lieferanschrift kann abweichend voneinander sein # achten Sie bitte auf die Richtigkeit.
Der genannte Liefertermin ist einzuhalten, bei eventuell auftretenden Lieferverzögerungen ist uns umgehend Bericht zu erstatten.
Jeglicher Abweichung bedarf einer schriftlichen Auftragsbestätigung.
Aus Gründen der rationellen Auftragsbearbeitung bitten wir , von einer ausführlichen Auftragsbestätigung abzusehen und uns
stattdessen die Annahme dieser Bestellung durch die Rücksendung einer rechtsverbindlichen von Ihnen unterschriebenen Kopie
dieser Bestellung zu bestätigen.
Ihre Bestätigungsnummer:__________________
_______________, den __________ _____________________
Zwecks Fragen oder Anmerkungen melden Sie sich gerne bei dem Ihn bekannten Facheinkäufer
Mit freundlichen Grüßen
KAUFHAUSEN GmbH
- diese Bestellung ist ohne Unterschrift gültig -
Kaufhausen GmbH# Sitz und Registergericht: Konkursstadt # Registernummer: HRB 1111 # Geschäftsführer: Dipl.Ing. D.Katzenberger
Bankverbindung: Hessische Landesbank: IBAN: DE99 9999 9999 9999 9999 30 # BIC: WELA DE DD # USt-ID-Nr. DE 111111111
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)