import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[01]\\d|2[1-3]):[0-5]\\d(?::[0-5]\\d)?(?:,(?:[01]\\d|2[1-3]):[0-5]\\d(?::[0-5]\\d)?)*$";
final String string = "12:00,13:03:21,12:50";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}