#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([\w\.]+)\s*\d[\d\.\-]*\w*"
Local $sString = "3rosCore 2.0.9" & @CRLF & _
"3rosCore 2.0.9-rc" & @CRLF & _
"3rosCore 2.0.8" & @CRLF & _
"3rosCore 2.0.8-rc" & @CRLF & _
"3rosCore 2.0.7" & @CRLF & _
"3rosCore 2.0.6" & @CRLF & _
"3rosCore 2.0.5" & @CRLF & _
"3rosCore 2.0.5-rc" & @CRLF & _
"3rosCore 2.0.4-rc" & @CRLF & _
"3rosCore 1.0.7" & @CRLF & _
"3rosCore 1.0.6" & @CRLF & _
"3rosCore 1.0.5" & @CRLF & _
"3rosCore 1.0.4" & @CRLF & _
"3rosCore 1.0.3" & @CRLF & _
"3rosCore 1.0.2" & @CRLF & _
"3rosCore 1.0.1" & @CRLF & _
"3rosWeb 2.0.0-rc" & @CRLF & _
"3rosWeb 1.0.2-rc" & @CRLF & _
"3rosWeb 1.0.1" & @CRLF & _
"3rosWeb 1.0.0" & @CRLF & _
"3rosWebApi 2.0.0" & @CRLF & _
"3rosWebApi 1.0.0" & @CRLF & _
"Actsis.ECharts.Standard 8.0.1695-beta" & @CRLF & _
"Actsis.ECharts.Standard 8.0.1691-beta" & @CRLF & _
"Actsis.ECharts.Standard 8.0.1689-beta"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")