using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^produto\/?([-\w.]+)\/?$";
string input = @"produto.php";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}