#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\+?(?:00)?(?:49|\(49\))|\(\+49\))(?:[ ()-]*\d){10}$"
Local $sString = "+491739341284" & @CRLF & _
"+49 1739341284" & @CRLF & _
"(+49) 1739341284" & @CRLF & _
"+49 17 39 34 12 84" & @CRLF & _
"+49 (1739) 34 12 84" & @CRLF & _
"+(49) (1739) 34 12 84" & @CRLF & _
"+49 (1739) 34-12-84" & @CRLF & _
"0049 (1739) 34-12-84"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")