$re = '/[^\r\n]*\r*\n|[^\r\n]+$/';
$str = 'abcdef
ghi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);